May 21, 2014

MightyFrame Boot Screens

Our next step in restoring one of our Convergent Technologies MightyFrame Machines is to get one of them to boot to a working operating system.  These systems were designed to run CTIX, a Convergent branded version of UNIX, so far as we have learned.

See our search for the CTIX install OS QIC tape.


Meanwhile, for those of you who may be familiar with the AT&T 7300 / 3b1, we welcome your input reviewing our screen shorts of our attempts to boot both of our MightyFrames.



We are using a ZOC terminal emulator for this testing.  You may notice the top line, which usually says:  
[SERIAL/DIRECT] CONNECTED TO PORT com17 (9600-8N1)

To avoid confusion, this is the ZOC result when connecteding to the COM port adaptor on our modern Windows 7 machine, which is then plugged into the Channel 0 RS-232 (db25) port of the MightyFrame.  Every line after this is written by the MightyFrame.  

NOTE:  We are testing with a blank or "unknown" system backup tape, since we cannot find any MightyFrame or CTIX tapes, so we are not surprised when we see all of the "No Data" messages when we have a tape inserted in the tape drive.  At least it is trying.

But why does it never indicate that it is trying to boot from the hard drive?  How do we know that it is or is not trying or recognizing the hard drive?  (Maxtor XT-2190 last used one of these machines).

Thanks for your input!

-AJ









MightyFrame CG-5140 Boot Screen - Text:


No peripherals:

MightyFrame PROM Version 1.3
available memory:0x500000 mapped as:F1
memory frames 100 - 200 not present
memory frames 200 - 300 not present
memory frames 300 - 400 not present

-------------------------------------------------

With Archive 5945L Tape Drive (no tape loaded):

MightyFrame PROM Version 1.3

available memory:0x500000 mapped as:F1
memory frames 100 - 200 not present
memory frames 200 - 300 not present
memory frames 300 - 400 not present
tape status:D0810000 WP NOCART RESET
tape status:D0000000 WP NOCART
CTIX was not running - no dump needed
checking memory at 400000 [ addr ~addr parity ]
checking memory at 500000 [ addr ~addr parity ]
checking memory at 600000 [ addr ~addr parity ]
checking memory at 700000 [ addr ~addr parity ]
tape status:D0000000 WP NOCART
tape status:D0000000 WP NOCART
tape status:D0000000 WP NOCART
tape status:D0000000 WP NOCART
tape status:D0000000 WP NOCART
tape status:D0000000 WP NOCART
tape status:D0000000 WP NOCART
tape status:D0000000 WP NOCART
tape status:D0000000 WP NOCART
.......

seems to repeat forever...


2014-09-01 NOTE: trying the Maxtor XT-2190 from this machine connected correctly to D0, using the correct MightyFrame cables, the hard drive light blinks (off, otherwise sold on) for one "blip" every 9-12 seconds, then shortly thereafter, another line is written "tape status:D0000000 WP NOCART"

This increment of time is reduced to 4x/second or so for no hard drive, and about 1x/second or every other second with a Maxtor XT-2190 that was not originally from the MightyFrame.